Cannot connect Line-us to WiFi

I’m pretty lost on how to get Line-us working. I’ve tried setting it up with an iMac 27", and iPhone 12 Pro, and an Android Pixel 4, across 3 different routers (Google WiFi 1st gen, Eero Pro 6 mesh on both its primary and guest SSIDs, and GL-iNET 11n travel router on its unique-named dedicated 2.4GHz SSID), all with no success.

I have often been able to connect to the Line-us-Setup Wifi from each of these devices (all devices), and then connect to the Line-us from the Line-us app (all save the Pixel 4), picked my SSID from the scanned SSIDs, entered password, and then I get a message about updating the firmware (all devices) and to wait till the device shakes it arm (happens in most all cases although several times it never shakes arm after hours). In all cases, light ends up flashing blue and the Line-us never shows as connected in the app.

No VPNs, no special router setups that I’m aware of doing myself (and I’ve setup all three of these routers myself).

From other posts, I tried several of the suggestions:

#Could you try moving the Line-us closer to your WiFi router to see if it will connect

Yes, tried Line-us in 3 locations, within 6 feet or so, of different routers

#Could you try re-adding the WiFi network: Long press the button on Line-us to get to Red Mode, connect to Line-us-Setup WiFi on your MAC and then run the app. Click on the Setup WiFi icon and select your WiFi and click Forget:

No difference in results on re-add.

depends on whether your Line-us is run-in the latest firmware. Hopefully it is, in which case you can do the following: 1. Long press the button to get to Red Mode, 2. Connect your device to the WiFi Line-us-Setup, 3. In a web browser go to http://192.168.4.1

Only get a “This site can’t be reached” ERR_Connection_Refused error when attempting to go to 192.168.4.1 on both Safari and Chrome on both an iMac and an iPhone, when Line-us is flashing red and devices are connected to it via Line-us-Setup

Probably the best thing to try is a factory reset and then reconfiguring the WiFi: 1. Hold down the button while powering on the Line-us. Keep it pressed until the light flashes red very quickly. Then unplug the Line-us. 2. Power Line-us up again, go into red mode and add the WiFi.

Factory reset the device, setup the Line-us-Setup network again, followed all the steps, connect to one of the networks, get asked to upgrade to v3 firmware (skip it this time), Line-us app on iPhone says connected but light on Line-us continues to flash blue after Wifi setup, and when I restart iPhone app it says Not Connected and never re-connects.

#are you using any range extenders/powerline etc.

No.

Mac now shows “Searching for machine:l1i2n3e4u5s6” but never finds it.

ping 192.168.4.1 reliably comes back with:

PING 192.168.4.1. (192.168.4.1): 56 data bytes
64 bytes from 192.168.4.1: icmp_seq=0 ttl=64 time=0.644 ms
64 bytes from 192.168.4.1: icmp_seq=1 ttl=64 time=0.677 ms
64 bytes from 192.168.4.1: icmp_seq=2 ttl=64 time=0.784ms
64 bytes from 192.168.4.1: icmp_seq=3 ttl=64 time=0.809 ms

Line-us username: mlaaker

Thanks in advance.

Thanks to the kind help of Rob at help@line-us.com was able to get device connected. To help others in the future:

  1. Put Line-us into red mode by pressing and holding the button on top until it turns red.
  2. Connect your desktop device (in my case, a Mac) to Line-us-Setup Wifi (ensuring you’re NOT also connected via Ethernet or another connectivity link)
  3. Start the Terminal app
  4. Connect to your Line-us using the command:
    nc 192.168.4.1 1337
    Should result in a success message like
    hello VERSION:“3.2.0Beta7 Aug 27 2020 14:47:24” NAME:line-us SERIAL:1111111
  5. Clear any failed SSID/password settings with the following command
    M588 S*
  6. Then send your preferred Wifi configuration via this setup command
    M587 S"Your basestation SSID" P"yourSSIDpassword"
    (where each parameter in between the quote marks is obviously YOUR Wifi network’s SSID and password)