Plot from Inkscape/AI

Hi everybody,

just received my line-us and super excited.
I just found out tho that the inkscape extension is not working anymore.
Do you have any suggestion for me to make it work? I cant seem to understand any guide I found to update inkscape extension.
I tried also the SVG Plotter but apparently my drawings have something wrong it and wont load up.

Looking forward for your help.

Ciao

Hi,

  1. Which version of Inkscape are you using? We haven’t moved the extension over 1.0 yet but the older versions should work.
  2. Could you send me an example of an sag that’s not working with the SVG Plotter and I’ll see if I can find out why its not working.

I’m going to jump in here as I have a similar issue on both fronts, in case it helps narrow stuff down.

Inkscape running; and the extensions installs but just has but when you access the menu there is just a greyed out option saying LUS Control. I’ve tried with Line-Us app started and connected, and with the app closed.

SVG plotter, using the pre built app it performs all the on screen key triggered functions including successful connection (well it turns green) However it won’t plot the default image or a opened on. No feedback and I can’t see any means of getting logs.

In the SVG plotter, could you try hitting ‘a’ and entering the LineUs Address as ‘line-us.local’

For the Inkscape issue, could you let me know which version of inkscape you’re using.

Thanks
I managed to make it work on Inkscape with an older version on an older Mac :grinning:

Are these the only two options to draw something from a vector software?

That’s great. Inkscape 1.0 has some differences in the way extensions are implemented so there’s a bit of work to do to make it work. It’s on my to-do list though!

There are other SVG to GCode converters around but the two we list on the website are the ones we’ve worked with the most.

I haven’t had any luck with the Inkscape extension. Installed Inkscape 0.92 and the lus extension. Keep getting “Not connected”. Do I need to disable the line-us’s wifi so it will connect via the USB cable?

Are you on Windows or MAC? On windows you may need to add the version of Python that ships with Inkscape to Windows Firewall.

I’m using Windows. I’ve got these in the Inkscape extensions folder.

I’ll try installing Python. Thanks.

Also, which version of Inkscape 0.92 should I install… 32-bit or 64-bit?

Hi There,
I’ve tried to get this working without much success. The LUS menu doesn’t appear in the drop down, is this just for a Windows env? My set-up:
Inkscape 0.92
Linux Unbuntu
I have unpacked the zip into the named extensions DIR, but nothing is shown or picked up.
What should I be doing?

Many thanks
Pete

It’s not just Windows - I run it on a MAC (the extensions are Python). I haven’t tried on Linux but might be worth downloading a different extension to see if you can get any to work - maybe pick a simple and popular one…

Thanks Ron, let me try that. I don’t get any errors when running, so I’m slightly in the dark why it’s not working right now.

Looks like it doesn’t work in Linux:

/home/pete/.config/inkscape/extensions/._lus.inx:1: parser error : Document is empty

The document isn’t empty however and is the reported bytes from the zip file.
It works just fine in Windows.

Further error line was as follows:
** (inkscape:10917): CRITICAL **: 22:13:15.715: Inkscape::Extension::Extension* Inkscape::Extension::build_from_reprdoc(Inkscape::XML::Document*, Inkscape::Extension::Implementation::Implementation*, std::string*): assertion 'doc != NULL' failed

That’s odd - the ins file is the xml file with the config in. Could you send me a directory listing ls -la of the directory where you have the extension installed.

Rob I sorted it, many thanks. Looks like the file was corrupted, I’ve now got a fresh version and I’m in business. Phew.

That’s great - thanks for the update.